# apt install php7.0-dev

提示缺少依赖,缺多少就需要补多少,我缺少2个:libpcre3-dev 和shtool

现在下载缺少的依赖文件,官方下载地址:http://packages.ubuntu.com/xenial/php7.0-dev


点开即可看到全部依赖,点击进入后在页面下方找到下载部分,根据系统架构下载,X86_64对应AMD64,其他则对应选择。

如果麻烦可以直接点击右边下载,已经放在百度云了:点击下载

下载完成后,从最里层的文件开始开始安装,因为依赖可能有多层,这里只有2层目录,开始安装

#  dpkg -i install_package_name.deb

安装过程中如果仍然提示缺少依赖就继续下载再次安装就可以了,直到补齐所以依赖,一般是不缺的。

安装完成后,正式安装php7.0-dev

# apt install php7.0-dev

有了phpize之后就可以方便安装redis等扩展了

finished.